0
Under review

Trees don't transition perfectly when using Unity's builtin Anti-Aliasing

Aaron Brown 2 years ago • updated 2 years ago 1

Under review

This isn't necessarily a game-breaking issue, as the transitions still work pretty good. However, if you are seeing an unacceptably strong halo around your trees as the transitions are occuring, you can try turning off Unity's Anti-Aliasing in Edit->Project Settings->Quality.


If you need Anti-Aliasing to be on, you can try using an Anti-Aliasing asset from the asset store. Just make sure that the Anti-Aliasing effect is run AFTER the LushLOD post processing effect has finished.


Unfortunantly, there doesn't appear to be an option in Unity's scripting code to allow me to run the LushLOD post processing effect prior to Unity's Anti-Aliasing. And I think it would make sense that Unity should allow post processing effects to be run before its Anti-Aliasing, so I'm going to mention this on the Unity forum and hopefully they will make this possible in a later Unity version.