LushLOD Trees Support

Welcome to the support forum! If you are having any trouble with the trees, please be aware that LushLOD Trees is an early BETA product. There are still numerous glitches, and a lot of optimizations needed before these trees reach their full potential. In the mean time, I appreciate your patience!


Known Issues:


  • The trees have only been extensively tested on Windows platform.
  • The Post-Processor leaves a pixel-size distortion in the leaves.
  • Ultra quality isn't yet available for the TreeCreatorLeavesFast shader.
  • The billboards can sometimes cast real-time shadows on the HQ tree models.
  • The shaders use floats for everything, when lower-precision would sometimes work.
  • The shaders need lots of optimization (they were made in Shader Forge).
  • Billboard tree trunks don't always line up with HQ tree trunks on leaning trees.
  • Parent trees aren't always positioned in the most optimal locations.
  • The post processor performs more Blitz operations than may be necessary.
  • The post processor samples more pixels than may be necessary.
  • The trees do not always respond to real-time shadows from every source.
  • More documentation is needed.
  • No support for SM 2.0

You can help me make these trees truly awesome by posting any bugs or glitches that you find. Before you submit a new idea or bug, please run a search first to make sure that your issue hasn't already been addressed.


+1
Fixed

Black Trees in Android build

Nige 1 year ago • updated by Aaron Brown 1 year ago 24

Hi Aaran,


So we fixed the problem with actually building an apk with Lush in our project but when we install on a device the trees just show as black planes on the tree branches (see attached image)


I know you have said that that this has not been tested on mobile and I also know that we will probably not get a fix in time for us to include in our build we are pushing tomorrow - which is really unfortunate as I really like your system. But have you any suggestions or ideas for why this is happening and what can be done to fix it?


We have tried enforcing OpenGLES 3 when publishing and are publishing to Android 7.0.



ANY help or ideas will be really great. Thanks in advance.  


0
Answered

so it supports only Unity Tree Creator ? but not custom mesh trees?

Igor Levochkin 3 months ago • updated by Aaron Brown 3 months ago 1
0
Under review

error converting trees

jburnsnotice 4 months ago • updated by Aaron Brown 4 months ago 1

Hi! Thanks for the cool product. I get this issue when trying to convert trees from the "stylized Nature pack" by Mikael Gustaffson. By all the trees are poorly optimized, as in not at all. But they look great and fit my project so there ya go. Thanks for any help. Below is the console error that appears when in trying to convert those trees in  the tree converter scene


ArgumentNullException.Argument cannot be null.

Parameter name:shader


ArgumentNullException: Argument cannot be null.
Parameter name: shader
UnityEngine.Material..ctor (UnityEngine.Shader shader) (at /Users/builduser/buildslave/unity/build/Runtime/Export/Shader.bindings.cs:97)
_LushLODTreeConverter.DoAlphaPadding (Int32 downsample, Single blurSize, Int32 blurIterations, UnityEngine.RenderTexture source, UnityEngine.RenderTexture destination) (at Assets/LushLOD Trees/Scripts/_LushLODTreeConverter.cs:2228)
_LushLODTreeConverter+<CreateBillboard>c__Iterator1.MoveNext () (at Assets/LushLOD Trees/Scripts/_LushLODTreeConverter.cs:942)
UnityEngine.SetupCoroutine.InvokeMoveNext (IEnumerator enumerator, IntPtr returnValueAddress) (at /Users/builduser/buildslave/unity/build/Runtime/Export/Coroutines.cs:17)


0
Under review

how many tree i can handle it fast when loading?

cocowen 6 months ago • updated 3 months ago 14

i use mapmagic spawn 300 tree , it take me 5s to loading the game ,but when i spawn 1500 trees , it always loading , at least 3mins ,i have to close unity , my plan is to create 5000 , what should i do 

0
Under review

Definition missing:

JamesWjRose 6 months ago • updated 6 months ago 2

I just purchased your asset, however when I open Unity (2107.3.1f1) I get 6 errors that state:  "Assets/LushLOD Trees/Scripts/_LushLODTreeSceneConverter.cs(162,38): error CS1061: Type `Tree' does not contain a definition for `data' and no extension method `data' of type `Tree' could be found. Are you missing an assembly reference?"


Your class name is just "Tree" and could not find that class, I found the "_LushLODTree" class....   so, how do I fix this?

Also, if this helps, I added your trees to the Terrain section to paint the trees, but it did not do anything, not even an error.   It was when I rebooted and restarted the project that I got these errors.

0
Under review

Baked Billboards Black

Burak 7 months ago • updated by Aaron Brown 7 months ago 1

Hi there,

We are making a flight simulator. We need lots of trees and I created billboard trees from your models and materials. I placed the trees on the entire terrain with Gaia as seperate game objects and mesh baked them in groups. However after I bake my scene lighting, trees get black. When I import your asset again, trees go back to normal color. But when I re-open the scene, trees get back to black. I am using LushLODTree/Tree_Leaves2 shader. Can you help me?



0
Under review

LushLOD Trees in VR - you have no main camera

Daniel Todorov 8 months ago • updated by Aaron Brown 8 months ago 3

Hi Aaron,


Looking at your trees and the way they blend in VR is epic. I am having issues setting the whole system up. I get this message on the trees manager that says I dont have a camera enabled and it doesnt go away even after I enable a camera. Im running it on Unity 2018.1.0b12


Before posting I ran a few more tests and it works fine in an empty scene, but it doesnt in my main scene. Even after adding a camera called "Main Camera" it still didnt work. Any ideas?


Cheers


Danny

0

adding trees to gaia

David 9 months ago • updated by Aaron Brown 9 months ago 1

does anyone have a process for adding trees to the Gaia Manager?  I added them in put Gaia threw a bunch of errors and the trees didn't populate in the scene.  Still trying to work out what the issue is.

0

VR compatible without artefacts

BL1TZ 9 months ago • updated by Need Hymn 9 months ago 1

Hi,


I found  your asset on the unity assetstore and it said that LushLOD is VR compatible.

My only question is whether or not trees have "artefacts" when you look at them with a bright light behind it. I have tried some other tree assets as well in VR and in-between the branches (leaves) you can see white light distorting the Anti-aliasing and bringing up annoying artefacts.

I wanted to try your demo scene to test it with my HTC Vive headset, but I cannot seem to run the .exe file in VR Mode. Can you provide me with some feedback on how well this pack works in VR?


Warm regards

0
Under review

Wind affecting leaves, but not branches + weird shadow flicker in wind

miklelottesen 10 months ago • updated by Aaron Brown 4 months ago 7

I'm having a bit of problems with wind. Only leaves seem to be affected by wind zones, while the branches aren't affected at all, neither by main wind nor turbulance. This is unfortunate, because it makes the leaves appear disjointed when there's wind.


Another problem I'm having is that the shadows in the leaves are flickering a lot as they move in the wind, more notacible from certain angles. The flickering gets worse as the wind speed declines (though completely stops when there's no wind at all).


I'm using instantiated trees, not hand placed, so I had to modify the script a bit (we worked on this in a whole other thread) and therefore no baked shadows, only realtime. I've tried everything, including disabling ambient occlusion on the trees before converting them, but nothing seems to work. Any ideas what might be causing these issues?